Trouble exporting scene...

General questions and troubleshooting SOFTIMAGE©
Post Reply
User avatar
luis7654
Posts: 35
Joined: 14 Mar 2013, 19:14

Trouble exporting scene...

Post by luis7654 » 11 Jan 2018, 20:57

Hello guys I'm trying to export a scene just by copying the project folder, but when I open the scene on my friends computer everything is there except for the textures. Every texture is missing even though they are inside the same project folder, the only solution that I found so far is to replace every texture manually but there are many and it would be a nightmare to replace them all by hand. I was wondering if it is possible to export/share the whole scene/project in another way but still retain all the editability as if it was created on my friends computer I hope that makes sense... hopefully somebody can help me, thanks!

User avatar
rray
Moderator
Posts: 1473
Joined: 26 Sep 2009, 15:51
Location: Bonn, Germany
Contact:

Re: Trouble exporting scene...

Post by rray » 11 Jan 2018, 21:31

The textures might have been saved with absolute paths, which means you could try putting it on the same drive in the same subfolder as on your own computer. Worth a try at least
Softimage Resources section (formerly known as rray.de/xsi) updated Oct 01 2017

User avatar
mc_axe
Posts: 374
Joined: 12 Mar 2013, 18:44

Re: Trouble exporting scene...

Post by mc_axe » 11 Jan 2018, 21:56

Tell him ot try and save the scene with the copy all files option, it is supposed to bring copies of all xternal files like textures under the project folders, so you have them in one place, but i think it also adds relative paths. (not sure)

User avatar
luis7654
Posts: 35
Joined: 14 Mar 2013, 19:14

Re: Trouble exporting scene...

Post by luis7654 » 11 Jan 2018, 23:53

Thanks for the replies guys, I tried matching the folder names but apparently changing the username folder is very difficult so I kind of hit a brick wall there.

I didn't know that there was a copy all feature, i feel so dumb now... this brought most of the textures although still a lot of issues with the scene, but at least is progress, thanks!

User avatar
luis7654
Posts: 35
Joined: 14 Mar 2013, 19:14

Re: Trouble exporting scene...

Post by luis7654 » 12 Jan 2018, 00:28

Instead of renaming the windows username folder, I just created a new one and created all the same folders to match the paths and everything is working just fine. Thanks a lot guys! you saved me.

User avatar
myara
Posts: 349
Joined: 28 Sep 2011, 10:33

Re: Trouble exporting scene...

Post by myara » 12 Jan 2018, 04:59

I wrote a few years ago a tool to fix all my texture paths with a local path if the texture has been found inside the Project Folder.
It searches first for the texture file and it's parent folder name, just in case you are using 2 files with the same name but with a different folder inside your project folder.

https://www.dropbox.com/s/9eukrppmrieud ... th.py?dl=0

It's a script, run it from your Script Editor, or make a button in your shelf or Toolbar.

Oh, and don't forget to include your system folder, it can be hidden so be sure to make hidden folders viewable in your windows explorer preferences.
If your project folder doesn't have a system folder Softimage won't recognize it as a valid project.
M.Yara
Character Modeler | Softimage Generalist (sort of)

User avatar
luis7654
Posts: 35
Joined: 14 Mar 2013, 19:14

Re: Trouble exporting scene...

Post by luis7654 » 14 Jan 2018, 23:02

Awesome Myara! thanks a lot for sharing :D

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests